Agent with Version 1.9.24 Fails to Upgrade or Uninstall.

The error is "The Liongard agent is only supported on Windows Server 2008 R2 or better.".

❗️

Windows 2008 R2 and Below

We no longer support Agents deployed on Windows Server versions 2008 R2 and below.

The MSI that installed agents with version 1.9.24 had a bug in one of the validation checks it ran before upgrading or uninstalling the Liongard Agent. If you have installed the Liongard Agent on a server version > 2008 R2, but you see the below error when you try and upgrade, this document contains a workaround for upgrading or installing your 1.9.24 Liongard Agent.

Workaround

  1. Download this repaired MSI build, which is the MSI build for agent version 1.9.24 but with the corrected validation check.

  2. Update your server's launch condition cache by running the following command msiexec /i RoarAgent1.9.24.0-repaired.msi REINSTALL=ALL REINSTALLMODE=vomus. You can also run this silently from an Administrator command prompt with: msiexec /i RoarAgent.msi REINSTALL=ALL REINSTALLMODE=vomus /QN

  1. Next, download the latest MSI from your Liongard Instance.

  2. Run the installation/upgrade/uninstall process normally using the latest MSI. It's possible that you will hit an additional error where the MSI says there are not sufficient permissions to restart the service. In this case, you can exit the install and try the install again. The second time that you run the installer, it will go through without a problem.


Did this page help you?